Resolved
We are no longer seeing 500s on docs sites and are marking this incident as resolved. We will continue to add in further guardrails, testing, and monitoring over the coming days as follow-ons.
Monitoring
We have released another fix to ensure that stale 500s do not get cached, following logs showing residual errored pages getting stuck in an old error state. We are continuing to monitor the situation closely, please reach out to Fern if you see any outstanding issues.
Monitoring
We are seeing most 500s have resolved now, but are still continuing to monitor the situation and build better safeguards around this. If you are still seeing a 500 on your site, please reach out to Fern over Slack or email and we can help manually update your site to ensure forward stability.
Monitoring
We are seeing 500s drop and are continuing to monitor the situation for any residual errors.
Monitoring
We have now released a secondary fix and are monitoring closely to ensure full coverage of the issue.
Monitoring
We have identified issues that were causing 500s in the endpoint pages and have a fix out. We are monitoring this fix closely to ensure resolution.
We have also identified issues that were causing pages to occasionally incorrectly 404 and get stuck cached as such. We are implementing and releasing a fix to this now.
Investigating
We're currently investigating a service outage affecting API reference pages for some customers. If you are seeing 500 errors, we recommend upgrading your Fern CLI and republishing to help mitigate issues on your site while we root cause.